CSUSM - Microsoft 365 and Azure Issues – Incident details

Other experiencing major outage

Microsoft 365 and Azure Issues

Resolved
Degraded performance
Started 23 days agoLasted about 2 hours

Affected

Other

Degraded performance from 6:39 PM to 8:18 PM

Updates
  • Resolved
    UTC
    Resolved
    This incident has been resolved.
  • Investigating
    UTC
    Investigating

    Microsoft is reporting and some of our users are experiencing reduced availability and performance with M365 services including Teams, OneDrive, and SharePoint, among others. Microsoft is working to mitigate the issue. Details and updates can be found here: Microsoft service health status