CSUSM - Microsoft 365 Service Issues – Incident details

Microsoft 365 Service Issues

Resolved
Major outage
Started about 1 month agoLasted about 20 hours
Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Identified
    Identified

    From Microsoft:

    Root cause: A portion of dependent service infrastructure in the North America region isn't processing traffic as expected.

    Current status: We're carefully rebalancing traffic across all affected infrastructure in the region, while monitoring the corresponding health telemetry, to ensure the environment enters into a balanced state as our remediation efforts continue. We’re proceeding as quickly as possible and this incremental approach will also help us identify whether any additional actions may be required to ensure longstanding recovery.

  • Investigating
    Investigating

    Microsoft is currently experiencing a widespread service degradation affecting multiple Microsoft 365 services, including Outlook, SharePoint, OneDrive, and Teams. Microsoft is actively investigating and working to restore services. IITS is monitoring but be aware that there may be intermittent issues until Microsoft implements a resolution.