CSUSM - Microsoft Services Experiencing Intermittent Issues – Incident details

Microsoft Services Experiencing Intermittent Issues

Resolved
Major outage
Started 6 days agoLasted about 22 hours

Affected

Other

Major outage from 6:00 PM to 3:37 PM

Updates
  • Resolved
    Resolved

    This issue has been resolved.

  • Identified
    Identified

    From Microsoft:

    At this stage, we anticipate full mitigation within the next four hours as we continue to recover nodes. This means we expect recovery to happen by 23:20 UTC on 29 October 2025. We will provide another update on our progress within two hours, or sooner if warranted.

    Although we are seeing signs of recovery and have an estimated timeline, customers may also consider implementing failover strategies using Azure Traffic Manager to redirect traffic from Azure Front Door to their origin servers as an interim measure.

  • Investigating
    Investigating

    Due to an Azure Network outage (similar to the recent AWS outage), some Microsoft services are currently experiencing intermittent issues. Microsoft Teams, Microsoft Forms, and Dynamics 365 are among the services experiencing issues, but there might be additional services impacted.

    We are monitoring Microsoft updates on remediation and will post further when more information becomes available. You can visit CSUSM - Status (https://status.csusm.edu) and Azure status (https://azure.status.microsoft/en-us/status) for updates.